P&H v1.1b Q1 is grounding all injectors to MS case

http://jbperf.com/p&h_board/index.html

P&H v1.1b Q1 is grounding all injectors to MS case

Postby jsdevel » Thu Jul 27, 2017 2:29 am

Hi Jean,

My injectors stopped working, so I put my MS2 on the JimStim to troubleshoot. I noticed that all of the injector grounds were grounding to my MS case. On a hunch I disconnected Q1 from my MS case and the injector grounds are no longer grounding at the case. What would cause this to happen? Does it look like I have them installed properly?

IMG_20170726_230906.jpg
IMG_20170726_230906.jpg (1.77 MiB) Viewed 192 times
jsdevel
 
Posts: 28
Joined: Tue May 31, 2016 8:04 pm

Re: P&H v1.1b Q1 is grounding all injectors to MS case

Postby rickb794 » Sat Aug 26, 2017 10:36 am

Have you resolved your problems?

Did the problem appear on all 4 injection channels?

See http://forum.jbperf.com/viewtopic.php?f=4&t=1652 jean's reply at the bottom?

And

http://forum.jbperf.com/viewtopic.php?f=4&t=1636
rickb794
 
Posts: 28
Joined: Sat Dec 18, 2010 7:03 pm

Re: P&H v1.1b Q1 is grounding all injectors to MS case

Postby jsdevel » Mon Aug 28, 2017 12:04 pm

Have you resolved your problems?


Not yet.

Did the problem appear on all 4 injection channels?


Yes. All 4 are grounded and aren't working.

I'll checkout the links. Thanks!
jsdevel
 
Posts: 28
Joined: Tue May 31, 2016 8:04 pm

Re: P&H v1.1b Q1 is grounding all injectors to MS case

Postby jsdevel » Mon Aug 28, 2017 12:13 pm

Also, I have tested without the driver board using LEDs on a bread board, and I'm getting proper 5v signals on each injector. So basically, none of them are working through the board.

I did make the mistake of grinding off part of the screw attached to the heat sink with a dremmel. Is it possible I fried the TIP42C via static electricity? My Zener appears to be working properly.
jsdevel
 
Posts: 28
Joined: Tue May 31, 2016 8:04 pm

Re: P&H v1.1b Q1 is grounding all injectors to MS case

Postby jsdevel » Thu Aug 31, 2017 2:37 am

I ruled out Q1 as an issue. I really wish Jean were around. I could use the schematic.
jsdevel
 
Posts: 28
Joined: Tue May 31, 2016 8:04 pm

Re: P&H v1.1b Q1 is grounding all injectors to MS case

Postby jsdevel » Fri Sep 15, 2017 5:00 am

I figured it out! Turns out that all the TIP121's were fried. Ordered some compatible TIP122's from DigiKey and BOOM!

I was able to rule them as the issue when I had voltage at the base when testing the LM1949n's.

The lm1949n datasheet was extremely helpful.
jsdevel
 
Posts: 28
Joined: Tue May 31, 2016 8:04 pm


Return to Peak&Hold Driver

Who is online

Users browsing this forum: No registered users and 1 guest

cron