Page 1 of 1

Injectons stick open

PostPosted: Sat Sep 10, 2016 9:15 am
by gui67
Hello Jean,
I use a pair of 2.0a boards and siemens low impedance injectors with microsquirt.
It has been running fine for 5 years or more.

Now the injectors of output 1are stuck open.
I opened the case. The 5 volt is OK
Even when i disconnect the driver input, the driver keeps the 4 injectors open as soon as the power supply of the driver is provided. Also with the board out of the casing (so no risk of short circuit with thé transistors and thé case).

What should i do for tests ?

Thank you for your help.
Guillaume

Re: Injectons stick open

PostPosted: Sat Sep 10, 2016 1:19 pm
by jbelanger
The first thing is to make sure you have a good ground on the low current side. Then check if you have 5V on the board when you power it with your 12V supply. Check that each chip (U1-4) receives 5V on pin 7. Then check the voltage on pin 1 of the TIP122: you should have 0V with nothing connected to the input and a voltage over 1V if the corresponding input is grounded. Also, with nothing connected to the inputs, you should see 5V on them.

Jean

Re: Injectons stick open

PostPosted: Tue Sep 13, 2016 1:28 pm
by gui67
Hi Jean,
Thanks for your answer.
I will test it this week-end.
Is it possible to call you to get a feedback about the tests ans possible solutions in French ? It could be easier than through the forum.
Other question: there is still one driver for 4injectors on the car. Is it possible to wire the 8 injectors to the driver? Wiring 2 injectors in parallel for example for each output, but I wonder if the resistance divided by 2 could not damage the driver or if not, if the current would be enough to open them? Maybe as a temporary solution.

Re: Injectons stick open

PostPosted: Wed Sep 14, 2016 10:10 pm
by jbelanger
It will be difficult for me to get on the phone with you this weekend. Using email would work. PM me if you don't have my address.

As for using 2 injectors per channel, that's not a good idea. Unless the 2 injectors are perfectly matched, you may have one injector reaching a higher current faster and open while the second one doesn't open due to the lower current before the chip goes from peak to hold. And since the current is divided between 2 injectors, the hold current might not be high enough to keep the injectors open if they do open. At best you would end up with a 2A/0.5A peak/hold current.

Jean

Re: Injectons stick open

PostPosted: Sat Sep 24, 2016 10:30 am
by gui67
Hello Jean,
I am at the car, testing the driver.
The grounded of low crurent is OK.
I have 5V at the pin 7 of chips U1-4. (4,96V)
On the TIP122, there is 0,06V with the inputs connected to nothing.
And we have 1,06V with input grounded.

But when I measure the voltage at the input wires, i have only have 0,77V. Instead of 5V...

This is certainly the problem. Any idea why?

Re: Injectons stick open

PostPosted: Sat Sep 24, 2016 3:03 pm
by jbelanger
Actually, that is fine. There is a 5V pull up but since it is connected to the 2N3904 transistor (Q6-9), it will remain at this low voltage.

Check the voltage at pin 1 on U1-4. It should be 5V when the input is grounded and close to 0V when the input is left floating. But from what you say about what you see on the TIP122 pin 1, that should be ok.

That looks like either the TIP42 (Q1) or the 36V Zener (D1) are not working as they should and that is grounding the injector outputs. You should remove the TIP42 and check if the injector outputs are still always grounded or if the correctly react to the inputs. Don't run the board with injectors this way but simply check the outputs.

Jean

Re: Injectons stick open

PostPosted: Wed Oct 05, 2016 1:20 pm
by gui67
Thanks Jean,
I replaced the TIP42 and the Zener 36V and it is working now. I still have to install it on the car again.
Any idea what could have happened?

Re: Injectons stick open

PostPosted: Wed Oct 05, 2016 2:45 pm
by jbelanger
It is difficult to say. But if the metal tab did not have good thermal contact with the case, it could have overheated. Make sure that it lays flat and solid against the case and that you use heat sink compound.

Jean

Re: Injectons stick open

PostPosted: Sat Oct 15, 2016 1:14 pm
by gui67
We installed it in the car last week. It is running fine again.
My friend is happy to be able to drive it.
here are some pictures of the car and engine:
Image

Image

Thanks Jean

Re: Injectons stick open

PostPosted: Sat Oct 15, 2016 1:38 pm
by jbelanger
Nice!

And good to see everything is working as it should.

Jean

Re: Injectons stick open

PostPosted: Sun Apr 09, 2017 7:09 am
by gui67
Hello Jean,
My friend had just the same problem again, the right bank injectors open.
I did not open and checked the driver yet but I suspect the same cause.
It is strange that the driver is again damaged, only 6 month after being repaired when it worked without a problem during 6 years on my car.

Is it possible that the microsquirt running in batch, all injectors opening at the same time on the 4 inputs of the driver makes too much current compared to my car where I used a MS3 in sequential mode?

Guillaume