Serial port circuit failure?

Serial port circuit failure?

Postby elemental59437 » Sat May 14, 2016 8:00 pm

I searched this forum and the internet, so I appologize if this has been covered somewhere that I missed.

I have a JimStim v1.5 with both the V2.0.3 and V2.0.4 firmware chips. I have in the past been able to upload new wheel configs to it, but at some point it stopped working. It always comes back saying "Signature: Q" which is obviously the command to get the signature.

> I've tested with two FTDI cables on two laptops, both setups work with other devices. Both work in terminal when I jumper tx and rx.
> I've tested with both firmware versions, and the board does function with both as far as being an engine simulator, just no serial on either.
> I tested the resistor and diode in the serial circuit on the board, both seem to check out okay.
> The tach test from the build guide still works.
> Nothing seems to be getting hot.
> DIP 3,4,5,6 are on and 1,2,7,8 are off. JimStim is turned on
> FTDI cable is oriented the correct way.
> I've tried with power from USB and external power, same results each time.
> ECU is not connected to the JimStim while I am trying this, although I don't think that should affect it.

I have been looking for a schematic for these chips to be able to upload to it from a breadboard, but I am not too familiar with this CPU and haven't found anything valuable yet. Are there any other components on the board I should test? Is there a simple way to program this on a breadboard? I have a new JimStim kit on the way, but I am hoping to continue working while it's on the way if I can.
Posts: 3
Joined: Sat May 14, 2016 5:09 pm

Re: Serial port circuit failure?

Postby jbelanger » Sun May 15, 2016 9:26 pm

The schematics for the JimStim board is available on the main web page and the direct link is this:

You don't mention it but do you have the RX and TX jumpers installed as per this section?

One thing that I find suspect is that you say that you get "Signature: Q". That looks like you're not using a real serial port but rather a dummy port that simply does a loopback. Are you sure you're using the correct COM port number? You can try to use the mini-terminal in TunerStudio and send Q or S and see if anything comes back (set the baud rate to 9600).

Posts: 3633
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Serial port circuit failure?

Postby elemental59437 » Tue May 17, 2016 4:03 am

Hi Jean, Thank you.

I do have the RX and TX jumpers installed, forgot to mention that. I have tried both with power from the board and power from the FTDI cable.

From looking at the code, I believe I am getting 'Q' because that's what's in the buffer? It never gets overwritten by a read from the serial port because there is no response.

I am sure that I am using the correct COM port and the baud is set to 9600. I have have tested this in a couple terminal setups, and when the FTDI is not attached to the board, and I jumper tx and rx, I DO get a loopback. When the FTDI is attached to the JimStim, I get no response from it. I do have a bit more experience with software and serial connections than electronics, I feel pretty confident the problem is upstream from the FTDI but I could be wrong.

I'll be looking at the schematic to see if I can wire up a minimum circuit on a breadboard with spare components to flash it that way. If you could point me towards a datasheet or tell me the minimum pins I need to worry about, that would be of great help.
Posts: 3
Joined: Sat May 14, 2016 5:09 pm

Re: Serial port circuit failure?

Postby elemental59437 » Tue May 17, 2016 5:30 am

Ah, scratch that. I traced out a minimum circuit for flashing it on a breadboard, and it worked! Still not sure what may be wrong with the board, but at least I have the circuit notes to test it, and a workaround for now.
Posts: 3
Joined: Sat May 14, 2016 5:09 pm

Return to JimStim

Who is online

Users browsing this forum: No registered users and 2 guests