Volvo 5 cylinder now with dual VR board

http://jbperf.com/dual_VR/index.html

Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Mar 31, 2011 10:29 am

Hi All,

Well, I installed Jean's board in the MS3/X on this Volvo 850 (inverted 60-2 wheel, LS2 coils, half moon cam sensor) and it still won't start.

My first attempt was with falling edge ignition input capture and I noticed on the tooth log that it seemed to be missing every other missing tooth (116 teeth between long teeth) and the resulting sync error every other rev.

So I switched to rising edge and now I get every missing tooth. Well almost! What I now also get is a second tooth just before the long tooth that is a bit longer than the others. This makes me think I should go back to falling edge.....

Attached are tooth and comp and datalogs for falling edge (the earlier date stamps) and rising edge. MSQ attached too.

Waddaya think?

EDIT: Datalogs were too big. The error was error 2 for sync loss reason. All else seemed normal to me. MSQ and last log in next post.
Attachments
2011-03-31_10.09.11.csv
rising edge
(113.94 KiB) Downloaded 175 times
2011-03-31_09.58.21.csv
falling edge
(15.56 KiB) Downloaded 168 times
2011-03-31_09.56.45.csv
falling edge
(31.62 KiB) Downloaded 176 times
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Mar 31, 2011 10:39 am

Last log and MSQ for above post...
Attachments
2011-03-31_10.38.41.msq
(130.07 KiB) Downloaded 177 times
2011-03-31_10.10.38.csv
rising edge
(15.6 KiB) Downloaded 169 times
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Mar 31, 2011 11:15 am

Well, actually the car wants to run now, much better than when using the MS3 VR circuit.

But it can't keep sync.

Maybe the flaky injector driver on the MS3X board is causing too much noise.....

The car still syncs beautifully with no fuel on cranking ( in flood clear).
Last edited by bradyzq on Thu Mar 31, 2011 12:01 pm, edited 1 time in total.
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby jbelanger » Thu Mar 31, 2011 11:33 am

As we discussed before, I think that you need to try to eliminate that flaky driver from the equation. It obviously has some impact because you get sync when there is no electrical activity on the injectors. So you need to either get a new MS3X card or try the 3.57 board injector drivers as I suggested. But I understand that this is a pain to do due to the needed wiring changes.

And I tried to get a look at the logs but either they are weird or TS is having issues with loading and displaying them correctly. From what I've seen, it would be more likely to be the last and I'd need to have a look at the logs in a different way. But it is somewhat pointless until you see if you can get it running without the flaky driver.

Jean
Image
jbelanger
 
Posts: 3628
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Mar 31, 2011 12:00 pm

Yup, that's sadly the way it seems to be.

BTW, I wasn't implying in the least that your board wasn't doing the job! It was kind of neat to see a clean signal knowing that all the pot tweaking was effectively being done automatically by your board.

Hypothetically though, if the flaky driver was introducing noise, wouldn't it show up as additional teeth or something? The strangeness now is that the tooth count seems to be bang on yet I still get sync errors midway between missing teeth. The cam signal is between teeth too, both up and down.

Just wondering...
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Jun 23, 2011 12:16 pm

Long overdue update....

I replaced the defective MS3X board (it turned to be defective on one of the injector drivers, as suspected), and the car still would lose sync.

So, now it has a Cherry Hall sensor instead of the stock VR.

My question is "Do I have to remove the VR 2.0 or will it effectively become transparent due to its input being the same as the output??"
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby jbelanger » Thu Jun 23, 2011 12:32 pm

The dual VR 2.0 circuits can be used with Hall sensors. You just need to have a pull up like on any Hall sensor (5V or 12V doesn't matter to the VR circuit so use what the sensor needs or what is more convenient). If your sensor has an internal pull up then you, of course, don't need to add another one. Also, for a Hall sensor, you need to leave the VR- input floating, i.e., do not connect anything to it.

Jean
Image
jbelanger
 
Posts: 3628
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Thu Jun 23, 2011 1:47 pm

OK, will do.

So, for VR- in, I just cut the wire I currently have running from pin 3 on Q16 to VR1- of your board.

I will grab 12V for the Hall sensor from somewhere (suggestions? The easiest would be coil power, but it might be too noisy), and the signal will go back on VR1+.

So, VR- is now Hall ground, and goes to Pin 2 DB37 I think.

Where do I put the pullup? DIY said at R57 (currently unused), but I don't know if we've bypassed that part of the circuit or not.

Thanks!
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby jbelanger » Thu Jun 23, 2011 2:04 pm

bradyzq wrote:So, for VR- in, I just cut the wire I currently have running from pin 3 on Q16 to VR1- of your board.

Correct.

bradyzq wrote:I will grab 12V for the Hall sensor from somewhere (suggestions? The easiest would be coil power, but it might be too noisy), and the signal will go back on VR1+.

Noise on the power for the Hall sensor should not affect the output so you could try coil power if this is more convenient.

bradyzq wrote:So, VR- is now Hall ground, and goes to Pin 2 DB37 I think.

I'm not sure what you mean by VR- here but if you use a potentially noisy power source for the Hall it would be good to have a DB37 pin dedicated for the Hall ground, if that's not already the case. But otherwise that's correct.

bradyzq wrote:Where do I put the pullup? DIY said at R57 (currently unused), but I don't know if we've bypassed that part of the circuit or not.

R57 is perfect and since the dual VR board is connected to pin 2 of JP1 (if I remember correctly) then it's all connected as it should.

Jean
Image
jbelanger
 
Posts: 3628
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby bradyzq » Mon Jul 04, 2011 6:33 pm

It runs! and idles and revs! with no sync errors! on all cylinders! smoothly!

I haven't free-revved above about 4oooRPM, but so far all is well.

Thanks Jean!
Cheers, Brady
Audi 4kq MS1E,
Audi Quattro, 034 IIc
Audi 200qa20v
Datsun 240Z
bradyzq
 
Posts: 8
Joined: Sat Mar 19, 2011 12:23 pm
Location: Montreal, Quebec, Canada

Re: Volvo 5 cylinder now with dual VR board

Postby jbelanger » Mon Jul 04, 2011 7:10 pm

Brady,

I'm glad to see you got it running.

Jean
Image
jbelanger
 
Posts: 3628
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada


Return to Dual VR

Who is online

Users browsing this forum: No registered users and 1 guest

cron