injectors possibly holding on

http://jbperf.com/quad_ign_inj/index.html

injectors possibly holding on

Postby dannymo » Sun Apr 19, 2015 3:29 pm

the car was just running friday and on sunday it was dumping so much gas in it was reading 9 afr. so i did the test mode on injector 1 & 3 and they click. 2 and 4 will not. unplug the injector/spark connector and can get 2 & 4 to click by hand. Plug connector in and Injector 4 is holding at about 8v, and 2 is holding just under 10. disconnected the connector again and found that that they go back up to 12. so it looks like i may have something wrong with my board :(. I do have quite a bit of resin build up on it so i will have to clean that up first, but after that does anyone know how to test the board?
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm

Re: injectors possibly holding on

Postby dannymo » Sun Apr 19, 2015 9:26 pm

ok i think i narrow it down to the injector fet transistor things. does anyone know where i can get some of these?
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm

Re: injectors possibly holding on

Postby jbelanger » Sun Apr 19, 2015 10:25 pm

You can get the VND5N07 at Digikey or Mouser.

Also, make sure to heat the solder pad and not the tab when soldering the tab on the transistor. There is a possibility of putting too much heat in the component if you apply the solder iron more to the tab than to the pad on the board and that could lead to failure.

Jean
Image
jbelanger
 
Posts: 3627
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: injectors possibly holding on

Postby dannymo » Sun Apr 19, 2015 11:47 pm

thank you for the sources. I will make sure i do that. i don't know what exactly happen my guess maybe from all back to back cranking i did on them may have caused it. all i know is the two that don't work stay hot and have continuity from the two tap side to the 1 tab side and the one that is doing its job does not do that
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm

Re: injectors possibly holding on

Postby dannymo » Thu Apr 30, 2015 11:57 pm

is there any reason why my VND5N07 keeps burning up on injector 2 and 4? anything i can test for? everything i have checked look to be good.
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm

Re: injectors possibly holding on

Postby dannymo » Fri May 01, 2015 12:09 am

never mind just busted a pad off
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm

Re: injectors possibly holding on

Postby jbelanger » Fri May 01, 2015 12:12 am

Is that injector drivers 2 and 4 or is that injectors on cylinders 2 and 4 (which would be on drivers 4 and 3 if the firing sequence is 1342)? Do you have all 3 ground pins on the DB15 connector connected to a good engine ground?

Other than that, I'm not sure what specific could be checked. One test, would be to switch injectors around to see if the issue follows the injectors. But that's not a nice test if you have to see if you get another failure. But at least it would tell you if the injectors are part of the issue or not.

Jean

EDIT: I was writing that as you posted your last message.
Image
jbelanger
 
Posts: 3627
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: injectors possibly holding on

Postby dannymo » Fri May 01, 2015 12:18 am

thanks for your time. ya i messed it up. i will just have to rewire some things to just run semi sequential on the ms stock wires. i was just so stoked on doing sequential injection, but o well.

it was injector 2 and 4 not cylinders
dannymo
 
Posts: 14
Joined: Tue Mar 31, 2015 10:23 pm


Return to 4-Channel Driver

Who is online

Users browsing this forum: No registered users and 1 guest

cron