Remote Port3 bit 0

http://jbperf.com/io_extender/index.html
http://jbperf.com/io_extender/tinyIOx.html for the TinyIOx

Remote Port3 bit 0

Postby Mario » Tue Dec 27, 2016 6:20 pm

I'm using "Remote Port3 Bit 0" as my launch control input via PTE2 as a digital input on my TinyIOx.

I get get the raw bit changing from 1 to 0 as I enable the channel but I can't get the ECU to change with the port change. I also have an indicator that switches on ( Port3 & 1 ) and the indicator changes as well.

Here are my CAN Parameters
Screenshot 2016-12-27 14.17.02.jpg
Screenshot 2016-12-27 14.17.02.jpg (99.75 KiB) Viewed 861 times


Thanks!
1967 Bug 2276 F.I. Turbo, Megasquirt It!
Facebook-Website-Gallery
11.537 @ 115.74mph
236hp 245tq
Mario
 
Posts: 27
Joined: Tue May 04, 2010 12:06 am

Re: Remote Port3 bit 0

Postby jbelanger » Tue Dec 27, 2016 6:34 pm

You've got Port3 configured as an output: the setting for the direction says "2 inputs, 1 output" which means ports 1 and 2 are inputs and 3 is an output. So either change the port you're using or change the direction.

Jean
Image
jbelanger
 
Posts: 3545
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Remote Port3 bit 0

Postby Mario » Tue Dec 27, 2016 8:02 pm

Got it,

Ok. New settings and same result.

Screenshot 2016-12-27 15.50.40.jpg
Screenshot 2016-12-27 15.50.40.jpg (114.06 KiB) Viewed 858 times


Screenshot 2016-12-27 16.00.01.jpg
Screenshot 2016-12-27 16.00.01.jpg (97.75 KiB) Viewed 858 times


And my test project if you need it

Breakout Board Testing_2016-12-27_15.56.43.tsproj
(1.52 MiB) Downloaded 49 times
1967 Bug 2276 F.I. Turbo, Megasquirt It!
Facebook-Website-Gallery
11.537 @ 115.74mph
236hp 245tq
Mario
 
Posts: 27
Joined: Tue May 04, 2010 12:06 am

Re: Remote Port3 bit 0

Postby jbelanger » Tue Dec 27, 2016 8:21 pm

I just noticed that you used the default value for the offset for the port data (75). This is the full IOx value. For the TinyIOx, you need to use 45 instead of 75.

Jean
Image
jbelanger
 
Posts: 3545
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Remote Port3 bit 0

Postby Mario » Tue Dec 27, 2016 8:49 pm

That was it :D

Thanks Jean!!
1967 Bug 2276 F.I. Turbo, Megasquirt It!
Facebook-Website-Gallery
11.537 @ 115.74mph
236hp 245tq
Mario
 
Posts: 27
Joined: Tue May 04, 2010 12:06 am


Return to I/O Extender

Who is online

Users browsing this forum: No registered users and 4 guests

cron