Trouble connecting MTX-L in Tiny IOx

http://jbperf.com/io_extender/index.html
http://jbperf.com/io_extender/tinyIOx.html for the TinyIOx
Post Reply
rotorhead87
Posts: 3
Joined: Fri May 04, 2018 3:51 pm

Trouble connecting MTX-L in Tiny IOx

Post by rotorhead87 » Fri May 04, 2018 4:01 pm

I have a MS3X running 1.5 and a Tiny IOx the latest firmware and I can't get any data from my MTX-L.
I've followed all of the instructions I have found, but I Can't even see anything in the Data>Realtime Display section. What am I missing?

I have attached my current MSQ files.
Attachments
CAN1_CurrentTune.msq
(39.24 KiB) Downloaded 39 times
CurrentTune.msq
(285.01 KiB) Downloaded 38 times

jbelanger
Posts: 3655
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada
Contact:

Re: Trouble connecting MTX-L in Tiny IOx

Post by jbelanger » Fri May 04, 2018 6:18 pm

Your settings look ok (but there are a few unrelated things that are not quite right). Can you describe exactly how the MTX-L is connected to the TinyIOx. Also, posting a short datalog would be helpful. Make sure that the realtime data is enabled for the TinyIOx.

Jean
Image

rotorhead87
Posts: 3
Joined: Fri May 04, 2018 3:51 pm

Re: Trouble connecting MTX-L in Tiny IOx

Post by rotorhead87 » Fri May 04, 2018 11:33 pm

I have the 2.5mm cable plugged into the serial port (via a official innovate molex-2.5mm adapter cable). I won't be able to get a data log until tomorrow. It's been sitting on my work bench for a couple years. I never took it out of the package it was shipped in, but I hope nothing happened to it.

What were the other things that weren't right? I was trying a bunch of stuff until I realized I couldn't even see it in the realize display.

jbelanger
Posts: 3655
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada
Contact:

Re: Trouble connecting MTX-L in Tiny IOx

Post by jbelanger » Sat May 05, 2018 12:01 am

It's nothing bad but you have the ADC, digital I/Os and PWM inputs enabled but none of those have any channel enabled. And on the MS3 side, you have the ADC polling enabled but no ADC group enabled and polling of the digital inputs but there is nothing to poll on the TIOx.

Those won't cause any issue but it is always better to be consistent and disable what you're not actually using.

As for the MTX-L connection, since you're using the Innovate cable there should not be any issue on this side. I'll have to wait for a datalog to see where to go from here.
Image

rotorhead87
Posts: 3
Joined: Fri May 04, 2018 3:51 pm

Re: Trouble connecting MTX-L in Tiny IOx

Post by rotorhead87 » Sat May 05, 2018 5:28 pm

So it turns out I'm just stupid lol. I had it plugged into the "in" port on the MTX-L instead of the "Out" port. Once I swapped it everything is going great! And thanks for the tips on the other stuff, I'll get it swapped around.

jbelanger
Posts: 3655
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada
Contact:

Re: Trouble connecting MTX-L in Tiny IOx

Post by jbelanger » Sat May 05, 2018 5:37 pm

Good to see it was that simple and that it is now working. And we all make stupid mistakes; it's good when the only consequence is a bit of lost time.

Jean
Image

Post Reply