Injector bank 3 and 4 doesn't works.

http://jbperf.com/quad_ign_inj/index.html

Injector bank 3 and 4 doesn't works.

Postby Viroslash » Thu Oct 25, 2012 10:47 am

Hello! I have installed the 4-channel driver only for sequential fuel.
I have made the PCB modifications and removed the necessary components.
I loaded the firmware and enabled sequential/semi-sequential injection with aditional drivers, but still working as alternating mode, inj3 and inj4 doesn´t works. What can be wrong?

Image
Image
Image
Image


Thank you, hugs.
Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am

Re: Injector bank 3 and 4 doesn't works.

Postby jbelanger » Thu Oct 25, 2012 11:41 am

The hardware looks to be as it should. Please post your msq so that I can have a look at your settings.

Jean
Image
jbelanger
 
Posts: 3621
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Injector bank 3 and 4 doesn't works.

Postby Viroslash » Thu Oct 25, 2012 2:10 pm

MSQ uploaded.
Attachments
viroslash.msq
(80.04 KiB) Downloaded 195 times
Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am

Re: Injector bank 3 and 4 doesn't works.

Postby jbelanger » Thu Oct 25, 2012 2:20 pm

Why are you using such an old firmware version? The first thing you should do is load the latest stable code which is 3.2.4: http://www.msextra.com/doc/ms2extra/fil ... elease.zip.

Jean
Image
jbelanger
 
Posts: 3621
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Injector bank 3 and 4 doesn't works.

Postby Viroslash » Thu Oct 25, 2012 3:24 pm

This version is not compatible? Is alpha pre3.0.3i
In this moment I dont have the rs232 cable, only bluetooth adapter, I try to upload the new firmware but I cant.
Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am

Re: Injector bank 3 and 4 doesn't works.

Postby jbelanger » Thu Oct 25, 2012 5:01 pm

It should be compatible but I don't want to try to troubleshoot a 3-year old firmware version. There has been many bug fixes since then, not to mention numerous improvements, and you may simply be seeing one of them.

Jean
Image
jbelanger
 
Posts: 3621
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Injector bank 3 and 4 doesn't works.

Postby Viroslash » Mon Oct 29, 2012 6:51 am

Firmware 3.4.2 loaded, same problem :(

http://youtu.be/lsswmYpN-KQ
Attachments
churro_sec.msq
(83.53 KiB) Downloaded 138 times
Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am

Re: Injector bank 3 and 4 doesn't works.

Postby jbelanger » Mon Oct 29, 2012 10:30 am

The problem you have is that you're not setup to use the cam signal. You only have a single missing tooth wheel. To have sequential injection you need a cam signal so you need something like a dual wheel with missing tooth setup. And that also means you need to connect a spare pin on the DB37 to JS10 and connect the cam signal to that pin.

By the way, saying that injector banks 3 and 4 don't work when the LEDs light up is misleading. They do work but not in a sequential way. And semi-sequential, which is what you currently have, looks exactly like the alternating mode.

Jean
Image
jbelanger
 
Posts: 3621
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Injector bank 3 and 4 doesn't works.

Postby Viroslash » Mon Oct 29, 2012 11:55 am

I believed that for semi-sequential injection the second sensor wasn´t necessary. Sorry.
Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am

Re: Injector bank 3 and 4 doesn't works.

Postby jbelanger » Mon Oct 29, 2012 12:20 pm

It is not necessary for semi-sequential. But what you are seeing is exactly what semi-sequential is. What were you expecting to see? Semi-sequential injection is similar to wasted spark: on a 4-cylinder, you have 2 cylinders that are injected at the same time once per rev. So inj1 and inj3 are fired at the same time and inj2 and inj4 are fire at the same time 180 degrees later.

You will only see the 4 channels fired one by one in succession if you are set for full sequential, i.e., you have a cam sensor, or if you are configure for an 8 cylinder in which case you get 4 injection pulses per rev (one every 90 degrees).

Jean
Image
jbelanger
 
Posts: 3621
Joined: Sat Oct 03, 2009 12:24 pm
Location: Quebec, Canada

Re: Injector bank 3 and 4 doesn't works.

Postby Viroslash » Fri Nov 02, 2012 5:22 pm

Viroslash
 
Posts: 13
Joined: Wed Sep 26, 2012 7:57 am


Return to 4-Channel Driver

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron